Introduction to IBM Data Studio, Part 1: Get started with IBM Data Studio, Version 1.1.0 and Eclipse

Install, work with data perspectives, create connections, and create a project

Skill Level: Intermediate

Debra R. Eaton (deaton@us.ibm.com)
Consulting Information Technology Specialist
IBM

01 Nov 2007

Based on open source Eclipse technology, IBM® Data Studio, Version 1.1.0 gives DB2® V9.5 database developers the ability to develop database application objects that access data in a number of data servers and replaces IBM DB2 Developer Workbench (DWB). Get an introduction to the Eclipse user interface and basic data development tasks.

Section 1. Before you start

Find out what to expect from this tutorial and how to get the most out of it.

About this series

This tutorial is part of a series that explores the many features of the Data Studio data perspective and its associated views, wizards, and editors. Because this tutorial's focus is the Data Studio tooling and not coding techniques, the code samples are basic and use the DB2 SAMPLE database.

About this tutorial

This tutorial takes a basic approach to working in Data Studio's Eclipse environment, explaining user interface concepts and offering steps for creating connections.
Objectives

In this tutorial:

• Install Data Studio
• Learn Eclipse terms, such as resources, perspectives, views, editors, and wizards
• Start Data Studio
• Connect to a server
• Manage connections
• Create a data development project
• Explore teaming options

Prerequisites

This tutorial is written for database administrators and database programmers whose skills and experience are at a beginning to intermediate level. You should have a general familiarity with creating DB2 connections.

System requirements

To run the examples in this tutorial, you must install and configure the SAMPLE database that is included with DB2 V9.5. See the DB2 product documentation and first steps for more information. You will need installation access and authority to the Data Studio 9.5 source code. You must be able to connect to the SAMPLE database with a user ID and password.

If your installation of Data Studio is new, your perspectives (Eclipse views) will be empty. The figures used in this tutorial contain resources because the Workbench contained existing projects. Once you create a project in this tutorial, your Workbench will contain similar resources.

The schema used throughout this tutorial is "DEATON". Replace the "DEATON" schema with your schema, represented in the instructions by SCHEMANAME, when a task requires a schema name.

Section 2. Install Data Studio
This section steps you through the Data Studio installation process. In this section, accomplish the following goals:

- Verify your user ID has administrator authority
- Start the Installation Manager
- Select IBM Installation Manager options
- Install the Software Manager options

Verify your user ID has administrator authority

1. From the Windows desktop, select Start > All Programs > Control Panel > User Accounts. Verify your user ID has administrator authority. Figure 1. Administrator authority

Start the Installation Manager

1. Double-click on `z:\InstallerImage_win32\install.exe`. Figure 2. install.exe

Select IBM Installation Manager options

1. In the Install Packages wizard, select IBM Data Studio and Version 1.1.0. Then select Next. Figure 3. Install Packages wizard
2. Select **IBM Data Studio**. Select the radio button for *I accept the terms in the license agreement*. Then select **Next**.

   Figure 4. Accept license agreement

3. In the Shared Resources Directory text box, select `C:\Program Files\IBM\SDP70Shared`, then select **Next**.

   Figure 5. Select the shared resources directory

4. In the Installation Directory text box, select `C:\Program Files\IBM\SDP70`, then select **Next**.

   Figure 6. Select the installation directory

5. Do not extend the Eclipse IDE. Select **Next**.

   Figure 7. Eclipse IDE
6. The default setting is English. Select **Next**.
   **Figure 8. English language setting**

7. Leave the default settings that are selected. Select **Next**.
   **Figure 9. Features**

**Install the Software Manager options**

1. Verify the disk space can accommodate the installation size, then select **Install**.
   **Figure 10. Select install**
2. Check for success status, then select Finish.

Figure 11. Successful installation

Section 3. Learn Eclipse and Data Studio terms

This section introduces you to basic Data Studio concepts. Data Studio is based on the open and extensible framework of the Eclipse Workbench. The Eclipse Workbench consists of:

- Resources
- Perspectives
- Views
- Editors
- Wizards

Resources

A resource is a collective term for the projects, folders, and files that exist in the Workbench. Typically, resources are viewed in a hierarchical format, which can be opened for editing. There are three basic types of resources that exist in the Workbench:

Files

Comparable to files as you see them in the file system.
Folders

Comparable to directories in a file system. In the Workbench, folders are contained in projects or other folders. Folders can contain files and other folders.

Projects

Contain folders and files. Projects are used for builds, version management, sharing, and resource organization. Like folders, projects map to directories in the file system (when you create a new project, you specify a location for it in the file system).

A project is either open or closed. When a project is closed, it cannot be changed in the Workbench. The resources of a closed project will not appear in the Workbench, but the resources still reside on the local file system. When a project is open, the structure of the project can be changed, and you will see the contents.

Figure 12. A project

Perspectives

A perspective is a group of views and editors in the Workbench window. One or more perspectives can exist in a single Workbench window. Each perspective contains one or more views and editors. Within a window, each perspective may have a different set of views, but all perspectives share the same set of editors. The data perspective is the perspective that database developers would most likely use.

Data perspective

The data perspective provides a set of functionality aimed at accomplishing specific data tasks or works with specific data resources.

Figure 13. Data perspective
Views

A view is a visual component within the Workbench that is used to navigate a hierarchy of information (such as the resources in the Workbench), open an editor, or display properties for the active editor. Modifications made in a view are saved immediately. Only one instance of a particular type of view may exist within a Workbench window. For basic tasks, a database developer uses the Database Explorer, Data Project Explorer, and the Data Output views.

Database Explorer

In the Database Explorer, you can connect to existing databases and browse database designs. You can also run stored procedures and user-defined functions then view the results in the Data Output view.

Figure 14. Database Explorer view
In the Data Project Explorer, you can work locally with data objects. The Data Project Explorer can hold data development projects, which include DB2 stored procedures, DB2 user-defined functions, Web Services, XML files, and SQL scripts.

**Figure 15. Data Project Explorer view**
Data Output view

In the Data Output view, you can see the messages, parameters, and results that are related to the database objects.

Figure 16. Data Output view

Editors

An editor is a visual component within the Workbench that is used to edit or browse a resource. Modifications made in an editor follow an open-save-close lifecycle model. Multiple instances of an editor type may exist within a Workbench window.

Figure 17. Editor
Wizards

A wizard is a visual component within the Workbench that is used to step a user through a series of tasks related to a resource. The purpose of the wizard is to make a task easy for you.

Figure 18. Wizard
Section 4. Start IBM Data Studio

This section steps you through the process to start Data Studio. In this section, accomplish the following goals:

- Start IBM Data Studio

Start IBM Data Studio

1. From the Windows desktop, select Start > All Programs > IBM Software Development Platform > IBM Data Studio > IBM Data Studio. Figure 19. Start menu option
2. Select the default Workspace, then select **OK**.

Section 5. Work with the Data perspective

This section steps you through the initial tasks of working with Data Studio. In this section, accomplish the following goals:

- Verify the Data perspective is active
- Expand and collapse view
- Move and dock a view
- Reset the Data perspective to the default settings
- Set options for the Data perspective

Verify the Data perspective is active

1. In the upper, left corner in the title bar, "Data" appears.

2. In the upper, right corner in the title bar, the Data icon is indented on the icon bar.

Expand and collapse a view
1. Double-click on the Data Project Explorer tab to expand the view to the full area.  
**Figure 23. Expand a view**

2. Double-click on the Data Project Explorer tab to collapse the view to the original size.  
**Figure 24. Data perspective**

Move and dock a view

1. With the left mouse button depressed, drag the Data Project Explorer view by its title bar to the right of the Database Explorer.  
**Figure 25. Drag a view**

2. Release the left mouse button. The Data Project Explorer view now appears to the right of the Database Explorer view.  
**Figure 26. Release a view**
Reset the Data perspective to the default settings

1. On the file menu bar, select **Window > Reset Perspective**, then select **OK** on the message window.  
   **Figure 27. Reset perspective**

2. The Data Project Explorer view now appears in the upper left corner.  
   **Figure 28. Default setting**

Set options for the Data perspective

1. On the file menu bar, select **Window > Preferences**.  
   **Figure 29. Preferences**
2. In the type filter text pane, select **Data > Output**. In the Output pane, set the **Maximum rows to retrieve** value to five, and select **OK**.  
**Figure 30. Preference option**
Section 6. Connect to a DB2 for LUW data server

This section steps you through the process of creating a connection to a DB2 for Linux®, UNIX®, and Windows® database with the New Connection wizard. The wizard is launched from the Database Explorer view. In this section, accomplish the following goals:

- Start the New Connection wizard
- Verify your new connection was created

Start the New Connection wizard

1. In the Database Explorer view, right-click on the white space within the view, and select New Connection from the pop-up menu. **Figure 31. New connection**

2. In the Select a database manager pane, expand the DB2 for Linux, Unix, Windows folder. Select All Versions. **Figure 32. Select a database manager**

3. In the User information pane, enter the password that matches your database user ID. **Figure 33. User information**
4. Select the **Test Connection** button to test the connection to the SAMPLE database.

**Figure 34. Test connection**

5. Select **OK** on the Connection to DB2 UDB is successful message window.

**Figure 35. Successful message**

6. Select **Finish**.

**Figure 36. Finish**

**Verify your new connection was created**

1. In the Database Explorer view, expand the **Connections** folder, and find the SAMPLE1 connection.

**Figure 37. Verify connection**

---

**Section 7. Connect to a DB2 for z/OS data server**
This section steps you through the process of creating a connection to a DB2 for z/OS® database with the New Connection wizard. The wizard is launched from the Database Explorer view. In this section, accomplish the following goals:

- Start the New Connection wizard
- Verify your new connection was created

Start the New Connection wizard

1. In the Database Explorer view, right-click on the white space within the view, and select **New Connection** from the pop-up menu.  
   **Figure 38. New connection**

2. In the Select a database manager pane, expand the **DB2 for z/OS** folder. Select **All Versions**.  
   **Figure 39. Select a database manager**

3. In the Connection URL details pane, enter the location name, host name, and port number that matches your z/OS server.  
   **Figure 40. Connection URL details**

4. In the User information pane, enter your database user ID and the
password that matches your database user ID.

**Figure 41. User information**

5. Select the **Test Connection** button to test the connection to the database.

**Figure 42. Test connection**

6. Select **OK** on the Connection to DB2 for z/OS is successful message window.

**Figure 43. Successful message**

7. Select **Finish**.

**Figure 44. Finish**

Verify your new connection was created

1. In the Database Explorer view, expand the **Connections** folder, and find the NDCDB20 connection.

**Figure 45. Verify connection**
Section 8. Manage connections

This section steps you through various options to manage your database connections. In this section, accomplish the following goals:

- Reconnect to a database
- View connection properties
- Edit connection properties
- Deploy a connection
- View the SAMPLE database tables and columns
- View table data
- Disconnect from a connection
- Delete a connection

Reconnect to a database

1. In the Database Explorer view, right-click on the SAMPLE database connection, and select Reconnect from the pop-up menu. Figure 46. New connection
2. Enter your user ID and password, then select **OK**.

   **Figure 47. Select a database manager**

3. In the Database Explorer view, expand the **Connections** folder, and find the **SAMPLE** database connection. The green square to the left of the SAMPLE folder represents the active connection.

   **Figure 48. Connection URL details**

View connection properties
1. In the Data Output view, located in the lower, right corner, select the **Properties** tab. View the properties for the SAMPLE connection. 

   **Figure 49. Verify connection**

   ![Image of Data Output view]

**Edit connection properties**

1. In the Database Explorer view, right-click the **SAMPLE1** (not the SAMPLE) database connection. Select **Edit Connection** from the pop-up menu.

   **Figure 50. Edit connection**

   ![Image of Database Explorer view]

2. In the Connection identification pane, change the connection name to **SAMPLEone**. Select **Finish**.

   **Figure 51. Select a database manager**

   ![Image of Connection identification pane]
3. In the Database Explorer view, expand the **Connections** folder, and find the **SAMPLEone** database connection.

   **Figure 52. Connection URL details**

**Deploy a connection**

1. In the Database Explorer view, select the **SAMPLEone** database connection. In the upper, right corner of the Database Explorer view, select the **Export Connection** icon.

   **Figure 53. New connection**

2. In the Export Connection window, create the directory C:\tempds. Enter the file name **SampleOneConnection**, then select the **Save** button.

   **Figure 54. Select a database manager**
3. In the Windows Explorer, change the directories to the C:\tempds directory. Double-click the SampleOneConnection.xml file to open the .xml file and view the connection information.

Figure 55. Connection URL details

View the SAMPLE database tables and columns

1. In the Database Explorer view, select the SAMPLEOne database connection. Expand the connection tree, selecting SAMPLE > Schemas > DEATON (use current system schema name) > Tables > CUSTOMER > Columns > INFO.

Figure 56. View a column
2. In the Data Output view, located in the lower right corner, select the Properties tab > Type tab. View the XML data type for the INFO column in the CUSTOMER table.

Figure 57. View column properties
View table data

1. In the Database Explorer view, right-click on the CUSTOMER table. Select Data > Sample Contents. 
   Figure 58. Sample contents

2. In the Data Output view, located in the lower, right corner, select the Results tab. View the sample data for the customer table. 
   Figure 59. Results

3. In the Data Output view, double-click on the ellipses (...) in the INFO column for the row that has a CID value of 1000. In the XML temporary file, select the Source tab and the Design tab. Expand the hierarchy tree in the Design tab. 
   Figure 60. XML results
Disconnect from a connection

1. In the Database Explorer view, right-click on the SAMPLEone connection, and select Disconnect.

Figure 61. Disconnect

Delete a connection

1. In the Database Explorer view, right-click on the SAMPLEone connection, and select Delete.

Figure 62. Delete a connection
Section 9. Create a data development project

Before you create routines or other database development objects, you first need to create a data development project to store routines and queries. You can also test, debug, export, and deploy these objects from a data development project.

A data development project is linked to a database connection in the Database Explorer. The wizards that are available in a data development project use the connection information specified for the project to help you develop objects targeted for that specific database. In this section, accomplish the following tasks:

- Create a data development project
- View resources in a project

Create a data development project

1. In the Data Project Explorer view, right-click on the white space within the view. Select New > Data Development Project.

   ![Data Project Explorer](image)

2. In the Project name field, type Basic. Select Next.

   ![Select a database manager](image)
3. Select **Use an existing connection**. In the Existing connections selection box, select **SAMPLE**, then select **Next**.

*Figure 65. Connection URL details*

View resources in a project

1. In the Data Project Explorer view, expand the **Basic** hierarchy tree to
view the available resource folders.

Figure 66. Verify connection

Section 10. Explore teaming options

Data Studio provides interfaces to teaming software. In this section, accomplish the following tasks:

• Explore teaming options

Explore teaming options

1. In the Data Project Explorer view, select Team > Share Project.

Figure 67. New connection
2. In the Select a repository type box, select **CVS**.

   *Figure 68. Select a database manager*

3. View the required repository location information. Select **Cancel**.

   *Figure 69. Repository location information*
Get started with IBM Data Studio, Version 1.1.0 and Eclipse
© Copyright IBM Corporation 1994, 2008. All rights reserved.
Resources

Learn

- **IBM Data Studio**: Get the resources you need to advance your skills on IBM Data Studio.
- **developerWorks Information Management zone**: Learn more about Information Management. Find technical documentation, how-to articles, education, downloads, product information, and more.
- Stay current with **developerWorks technical events and webcasts**.
- **Technology bookstore**: Browse for books on these and other technical topics.

Get products and technologies

- **IBM Data Studio**: Download Data Studio to try the exercises in this tutorial.
- Build your next development project with **IBM trial software**, available for download directly from developerWorks.

Discuss

- **Participate in the discussion forum for this content**.
- **Participate in developerWorks blogs** and get involved in the developerWorks community.

About the author

Debra R. Eaton

Debra Eaton has worked at IBM in DB2 Technical Sales as a software information technology specialist on the DB2 Migration Team for 13 years. She specializes in converting customer applications from non-DB2 databases to DB2. She has authored IBM Redbooks®, white papers, DB2 Magazine articles, and developerWorks tutorials on topics related to DB2 application development. In addition, she has presented these topics at IDUG and DB2 Technical Conferences.